Version

From Netfabb Wiki
Jump to: navigation, search

The list of functions is constantly growing. So take care to have the current version of netfabb Studio installed.

Contents

Changelog

netfabb 5.2 (2014/07/25)

General

  • netfabb Kinect Module: for the direct connection of a Microsoft Kinect scanner to make scans and load the scanned data directly into netfabb for fixing and further editing.

Private

  • Texture module: for creating colorful and textured parts

Professional

  • Japanese Translation
  • Advanced labeling Module: mass labeling for mass customization (available as a special module)
  • Texture module: for creating colorful and textured parts
  • Adavanced part orientation: rotate parts automatically in perfect alignment to the build platform or to surfaces of other parts
  • Multiple platforms module: for working with multiple platforms and build envelopes at the same time
  • Edit Single nodes of mesh: deform the mesh on a triangle level and move single nodes
  • Creation of reports and quotes also directly out of the measuring module

Selective Space Structures (3S Invent)

  • Advanced Surface Structures: apply complex structures to surfaces of models

Bugfixes and minor features

  • Translate part center to origin
  • Boolean Modul: more renaming possibilities
  • Slice aggregation

netfabb 5.1.1 (2014/04/03)

General

  • New shortkeys for selection and displaying
  • Show part names
  • Primitives renamed in Parts library
  • New border cutting in polygon cut
  • New Labeling module
  • Improved selection rectangle in repair mode
  • Improved repair context menu
  • Improved actions tab in repair mode

Professional

  • Report creation

netfabb 5.1 (2014/01/31)

General

  • Shortkey list included in manual
  • Improved menus in repair module
  • Reset button in Settings and Scaling dialog
  • Bugfixes

Professional / Private

  • Automatic report generation (Pro only): now includes part analysis and quote template
  • Mesh compare feature (Pro only): you can compare two similar models (after you have edited or fixed them) for their differences and find out if they lie within your tolerances. These will be made visible in terms of colours and numbers.
  • Remesh feature: If your part has a very irregular mesh, you can remesh the triangles and get a smoother shape. This is very helpful for scans and organic shapes.
  • MeshViewer: is able to colour a mesh and to remove all informations.
  • New MeshRepair scripts: reduce, refine, Prefix/Suffix
  • Improved selection rectangle
  • Close holes, close all holes, reduce triangles und fix flipped triangles work on all or only selected triangles.
  • New primitives: bracelet, vase, picture sweep, brick, fractal, rhombicuboctahedron
  • New file formats: Binvox, colorSTL, 3MF (in Windows only) and ZIP

Engines

  • New: OrthoDesk Engine
  • Rapidshape: New Basic Engine
  • Improved Fabbster Engine: new fillings, platform test

Bugfixes

  • Improved Boolean Operation
  • Automatic Packing: packing border fixed
  • Wallthickness bugs fixed

netfabb 5.0.1 (2013/10/08)

Professional

  • New feature: automatic report generation

Engines

  • Fabbster: firmware 6.91 + furthers improvements of the Fabbster engine
  • Improvements of RapidShape engine (e.g. better resolution of SLC Data, Russian translation)

Bugfixes

  • Surface cut in Mesh Repair fixed
  • Fixed slice export in Inch
  • Keep textures in plane cutting
  • Bugfixes for OBJ and ZPR files
  • Height/bitmap primitive: fixed aspect ratio
  • several minor bugfixes

netfabb 5.0 (2013/08/07)

General

  • release of new product netfabb Private
  • improved rendering
  • GUI
  • new dialog for rotation, scaling, translation
  • Undo Mesh Repair
  • bugfixes

Private

  • includes most features of netfabb Professional, for detailed description see netfabb Private (for private use only)

Professional

  • new included tool: Automatic Live Collision Detection
  • new included tool: Slice Commander (has been a seperate tool before - full functionality for editing and exporting slices)
  • Analysis features: Wall thickness, Center of gravity, Shadow parts, Upskin and Downskin analysis
  • Improved file formats: zpr, obj, ply, x3d, 3ds
  • new primitives: Bitmap and Heightmap to convert pictures into a mesh, convex hull
  • Mesh Repair: Wrap parts to have only one shell
  • Mesh Repair: Clip Planes for editing parts inside easily
  • Mesh Repair: 3D-Extrusion
  • Mesh Repair: Z-Compensation
  • Mesh Repair: Detect overlapping / nearby triangles
  • Mesh Repair: Refine triangle mesh
  • Mesh Repair: New automatic repair script
  • Mesh Repair: Mesh Viewer to display colors and texture
  • Mesh Manipulation: Smooth triangles
  • Mesh Manipulation: Reduce triangles

fabbster Engines

  • EASYSupport module
  • improved Buildstyles
  • kiosk mode for simpler handling
  • improved acceleration
  • improved installation wizzard
  • full support of heated platform and new gears

netfabb Studio 4.9.5 (2013/01/18)

General

  • bugfixes
  • redone primitives: new options (e.g. number of gears for helix)

Basic

  • new primitives: möbius strip, menger sponge, sirpinski pyramid, klein bottle

Professional

  • new primitives: bolt, nut and gear

Engines

  • new primitives: bolt, nut and gear


netfabb Studio 4.9.4 (2012/12/22)

Professional

  • added Simplified Chinese Translation
  • avoid 64bit crash of file open/save dialogs
  • stability fix in Slicing large hatched files
  • Enhanced netProject Functionality: Add Parts to existing scene
  • Automatic Packing Slice Export: Enable/Adjust Slice Reduction Tolerance
  • CAD Import Bugfix: Improved Assembly Import
  • Keyboard Shortcut for Auto-Arrange


Ultimaker Engine

  • released Linux version as Debian Package
  • avoid necessity of registering twice.
  • extruder retraction support
  • revised material calibration dialog
  • new buildstyles and Material settings (Reset Machine settings to apply)
  • Comb feature: No Retraction within one region
  • calibration bugfix: remove unused buildstyle entries
  • Autocalibration: easier to use
  • added configurable delays before fast jump
  • Always sort buildstyles by name
  • new Sorting Strategy of Contours and Filling
  • Bugfix: Extruder extrudes while changing raft
  • Minimal Cycle time: Do not reduce speed of fast jumps
  • Possibility to keep position between parts in Engine
  • Connect Direct Printing Overrides


fabbster Engine

  • new Firmware included v5.10
  • Warning dialog, if firmware too old
  • fabbster over Ethernet printing and discovery
  • added more explanatory error code descriptions
  • axis movement acceleration support
  • extruder retraction support
  • revised material calibration dialog
  • new buildstyles
  • Comb feature: No Retraction within one region
  • calibration bugfix: remove unused buildstyle entries
  • Autocalibration: easier to use
  • added configurable delays before fast jump
  • switch to new FAB file format. Transfer rate to SD Card is now 10x faster
  • AUTO.BGC is now called AUTO.FAB
  • Heated bed support
  • Update Wizard button highlighted
  • Sort buildstyles by name
  • new Sorting Strategy of Contours and Filling
  • Motors are disabled by default and can be enabled by double click on the main button
  • new Temperature Control Strategy
  • Support Type: External Support
  • Added Minimal Cycle Time
  • Bugfix: Extruder extrudes while changing raft
  • Connect Direct Printing Overrides
  • new USB Driver and Installer (important for windows 8 compatibility)


RapidShape Engine

  • new Factorysettings for Materials and Machines
  • Bugfix: netfabb could lose machine settings on some windows 7 systems
  • Use Slice Files as Input Data
  • Correct Boolean unification for Slices
  • New Volumetric Slicing and Rastering approach


netfabb Studio 4.9.3 (2012/09/04)

General

  • Czech translation
  • Ofixed OBJ export
  • improved stitching
  • improved diplicate faces removal

Professional

  • Boolean naming
  • reduced memory consumption for packing
  • seat-licensing
  • CAD import module
  • added 3D packing for medium and small platforms

Selective Space Structures

  • Split bars to even parts
  • Make tolerance of node spheres adjustable
  • Surfaces structures: STL files as surface cells, deformed according to the surface tringle quality

New engines

  • RapidShape
  • SLM

All engines

  • Movement Speed in Manualmovement
  • Bugfix: buildtime calculation
  • dense and hollow can be set for fill spacing
  • new primitives: lattice, lattice with hexagon profile, Möbius strip, Menger sponge, Klein bottle
  • comments in GCode optional
  • improved Z-jumps
  • additional z-jump can be set per region
  • buildstyles interface for less than 3 conturs bugfixed
  • dense and hollow can be set for fill spacing
  • commentar field for buildstyles and material shown by mouse drop over
  • interface errors in print tab sheets bugfixed
  • new manual control interface included (graphical assistance for mouse support, direct move to position)
  • software end switches
  • more precise calculation of buildtime
  • remaining buildtime shown
  • selective connect for different fabbsters
  • new interface for material settings
  • pause function

Ultimaker engine

  • default COM port Speed 250000
  • allow 255 COM ports

fabbster engine

  • test wizard for the fabbster hardware
  • fabbster driver is installed via netfabb engine
  • firmware updates via netfabb engine
  • new standard buildstyles
  • firmware 3.52
  • new fabbster platform

netfabb Studio 4.9.2 (2012/06/14)

General

  • undo for "delete part"
  • OpenGL 1.1 compatibility
Bugfixes
  • enforce file extension for projects
  • Fix Measuring Arrows
  • fixed access violation on mirror/invert
  • fixed x3d export for Linux

Professional

  • selfintersection removal/insertion scriptable
  • undo for "merge selected"
  • ZPR support
  • improved PNG export (monochrome PNG)
Bugfixes
  • duplicated path in filename at slice export

RepRap Engine

  • added Text primitive
  • fixed stringing on filling
  • advanced cool feature
Bugfixes
  • missing Refresh of tabsheets in Buildstyle editor
  • Bugfix for losing activation on systems with multiple hard discs

Fabbster Engine

  • includes all changes and bugfxes for the RepRap Engine
  • new Extruder
  • do not move to heating position
  • move to waiting position
  • volumetric autocalibration

Ultimaker Engine

  • includes all changes and bugfxes for the RepRap Engine
  • volumetric printing
  • improved toolpaths / print quality
  • easy printing with 50% speed and no fan for the first layer
  • unified outline feature for multiple part prints
  • improved minimal layer time feature
  • tweaked temperature to help prevent the frustration of filament grinding and increase layer stickiness


netfabb Studio 4.9.1 (2012/04/24)

General

Bugfixes
  • GUI fixes for MacOS
  • Render fix on some graphics cards
  • Bugfix: Drag+drop for Win64

Engines

  • Bugfix: Reprap Raft Stringing...
  • Bugfix: write Temperatures for Regions

Professional

  • optionally allow placement upside down in packing
  • PartImport: use Simple/Advanced triangle reduction as selected in settings

3S

  • Cut Simulation at mesh: Warning added
  • Surface structures: weights fixed, missing elements fixed

netfabb Studio 4.9 (2012/03/19)

General

  • GUI-Fixes for MacOS
  • Crash logger
  • no zoom after duplicating
  • simplified mesh export
  • SLC Import fix
  • Advanced Level of Detail
  • russian translation
  • NCM support for file preview browser
  • removed head tracking from stereographic view (not portable, did not work properly)
Bugfixes
  • prevent netfabb position beyond screen (fixes invisible netfabb on startup)
  • cancel calculations in Linux
  • LibXIOT Buffer Size fix
  • screenshots of current module

Professional

  • improved triangle reduction
  • improved smoothing
  • update license in license dialog
  • interlocking test analyzer
  • performance improvement for 3D packing
  • voxeljet engine

Ultimaker Engine

  • Demo without Serial Number
  • serial communication
  • GCode: retraction
  • MacOS: Direct Serial Connection
  • replaced M109 with M104
  • Custom GCode Header
  • Custom GCode + ModelInfos
  • removed heating position
  • fixed heated bed
  • Multi-ExtruderSupport
  • GCode rendering: fix for extruder change and offset
  • GCode handling: fan percentages
  • GCode handling: region overrides for temperature, speed, fan
  • comb feature
  • minimum skin feature size
  • negative offsets in volume filling
  • fix: build time calculation

netfabb Studio 4.8 (2011/09/23)

General

  • When you close netfabb and you have made changes since last saving the project, you will be asked if you want to save those changes before you close netfabb
  • You can center the view at any point on a part in the screen. Right-click on the point you want move to the center of the screen to and choose "Center view here" in the context menu.
  • Parts which consist of more than one shell are marked in the project tree. There is a little box at the top right of the color dot
Tree part with 2 shells.png
  • At the bottom of the tabsheet in the default module, there is information on how many parts you have selected, how many parts you have in your project in total and how many parts you have hidden
  • The Simple Cutting has been reworked. When you click "Execute Cut" you are directly linked to the Free Cut.
  • In the context menu after you right-click on a part in the project tree, you can Create a group with selected parts.
  • You can hide unselected parts in the View menu or in the context menu of the screen.
  • In the measuring tool, you can set default measuring options after right-clicking on the buttons in the tabsheet.
  • There is a new icon for the level of detail
  • support for Windows LNK-files
  • There are new keyboard shortcuts for the manual zoom. With 'Q' you zoom in, with 'A' you zoom out.
Bugfixes
  • The selection rectangle has been improved
  • Screenshots
  • Printing
  • Terminology fixes
  • TZCompressionStream.Seek error on saving fabbproject
  • Unicode fixes

Professional

  • Advanced part selection: You can select parts by their size, volume, part quality (e.g. all damaged parts) or number of triangles.
  • Advanced part import: Before importing parts, you can duplicate them, stitch them, scale them or change the level of detail. Additionally you can arrange your parts side by side in the platform.
  • Improved part export: A new export dialog for saving 3D parts offers new options. You can save many parts at once, either in one file or in separate files. With a loading list, you can save an XML file with which all parts you saved can be opened at once.
  • Polylgon cut: In the Free Cut module, you can draw a polygon line on the screen which is projected through the part. Everything within the polyon is then cut out.
The advanced part selection
The advanced import
The new dialog for the part export
A polygon cutting line
  • There is a new icon for the Free Cut module
    Free cut icon.png
  • Selection rectangle in repair: There is a new selection mode in the repair module with which you can drag a rectangle to select all triangles within that frame.
    Icon Triangleselectionrectangle.png
Drag a rectangle with the mouse.
The resulting selection.
  • As additional option for the feature Create Shell, you can create a hollow part. The inner hollowing shell is automatically merged with the original part.
  • The automatic placement by outbox has been renamed to Arrange Parts
  • Arrange parts 2D: When you "Arrange parts" you have an option to arrange parts two-dimensionally on the bottom plane of the platform.
  • In the settings, you can change how your parts are renamed after editing or repairing them.
  • Ungroup: You can disband groups in the project tree. The contained parts remain in the project.
  • In the Platform Overview you can now export a plain list of part names
  • Whenever any parts are selected and you press "P", a second platform is shown, with the coordinates of the selected parts as origin
  • Improved slicer. The slicing of 3D parts and creation of slice file has become faster.
  • PLY, GTS and OBJ export
  • SSL V20 export
  • The Professional Tool Live Collision Detection has been redone
Bugfixes
  • When netfabb looses its connection to the dongle, you can recover your work after reconnecting.
  • "Show prehatches" of slices has been fixed for Windows 7

3S

  • Merge selected nodes
  • Bar splitting
  • CSV export: You can save a list of all structure cells in a CSV file.
Bugfixes
  • Cell "nothing" was misinterpreted as "solid"

RepRap Engine

  • completely redone

netfabb Studio 4.7 (2011/05/23)

General

  • Hide and show groups: With the options "Hide Group" and "Show Group", you can hide all parts of a group at once. You can choose that option in the context menu, after you right-click on the group, or by clicking on the eye next to the group in the project tree.
Hide and show group context.png Hide and show group eye.png
  • Stereographic View: With the option "Stereographic View" in the View menu, you can see your parts with a 3D effect. You can have your parts rotate automatically to get a motional effect. You need 3D glasses to see the effect (with a blue and a red foil) and you can choose from a number of color schemes in the software to get the right setting for your glasses.
  • In the measuring tool, when you hold the left mouse button to set the last anchor of a measuring, you can see a preview of the measured value as you move the mouse over the part surface.
  • Redesigned slice export: The export of slice files has been completely redesigned, as you can edit various settings, depending on file type, in a new kind of dialog window and you can choose the file type in that dialog window.
The dialog window for exporting slices.
  • In the options for the Simple Cutting and in the measuring tool, you can now set cutting planes with the mouse. If you right-click on the orange box next to the axis letter in the tabsheet and choose the option "set cut", you can click anywhere on the part to insert a cutting plane. That cutting plane is inserted across the chosen axis and goes right through the point you clicked on. If you hold the left mouse button, a transparent plane is displayed as a preview. You can move it across the part per drag & drop. It is not inserted until you release the left mouse button.
The preview to a cutting plane, set with the mouse.
  • If the option "Show Platform" in the View menu is activated, the outline of the platform is also shown in the Slice Commander as rectangular box starting in the origin of the coordinate system
  • Parts can be exported as AMF files. It is planned to make this format the new standard for Additive Manufacturing. There is a new export dialog, which allows you to export several parts as one file or several parts at once as separate files.
  • improved Linux port
  • MacOSX port
  • Support for Generic GCode Files (GCD) an Binary GCode Files (BGC): You can open GCD and BGC files and analyze them in the Slices section.
  • MTT and CLF files can be opened and are inserted in the Slices section.
Bugfixes
  • Incorrect measurings for changed parts: If you have a part with a measuring, then change that part (for example scale it) and then start another measuring, you now get updated results.
  • Internationalization fixes (translation mistakes etc.)
  • Libxiot for linux
  • Checkboxes in file extention dialoge with Windows 7 are no longer missing
  • Already opened files can now be viewed in the file preview browser as well
  • Rounding errors in volume calculation for big parts are fixed

netfabb Studio Professional

  • There are two new options for the part analysis. The Upskin/Downskin analysis identifies the top and bottom surfaces of a part. You can define an angle. All surface areas whose angle to the X-Y-plane is below the specified angle are defined as upskin or downskin, depending on their orientation upwards or downwards.
  • The Shadow area analysis projects the volume of your part to the X-Y-plane. You get a sort of shadow the part casts on the bottom plane of its outbox. The area of that shadow is calculated.
Upskin and Downskin Analysis: The upskin of this sphere is colored blue, the downskin is colored green.
Shadow Area Analysis: The shadow of this part is projected to the bottom plane.
  • Drag Files into Repair: When you repair a part, you can add other parts to the repair module by drag & drop in the project tree. That can be used to combine parts. If you combine this feature with the function "Extract selected Triangles as Part", you can, for example, move shells or areas of your part out of the repair, edit them indepently and then drag them back into the repair.
  • When you export slices, it is possible to save many slices as one file or many slices at once in separate files.
  • If your netfabb license is temporarily limited, the expiration date is shown in the license information (in the Help menu). Usually, your license is non-expiring. You only get a limited license, if you have newly ordered the software and pay afterwards. As soon as payment arrives, a non-expiring license file is sent to you.
Bugfixes
  • Shells marked in the Shell List can be deleted
  • SLC export fixed

Slice Commander Professional Tool

  • You can export and import ABF and CLF files.
  • Calculations are applied automatically when you export slices.

Selective Space Structures

  • You can insert conical bars
  • You can export nodes as spheres. Selected nodes can be included in the structure. That way there are no open gaps between bars.
  • It is possible to create hollow bars
  • Enhanced profile editor
  • In the 3S Executor, you can split fragments into connected components
  • You can select and separate single raster cells in the 3S Executor
  • STEP export for simulations
  • Custom color for cutting tool
Bugfixes
  • Selection of fragments bug is fixed

netfabb Engine for RepRap

  • Completely new Engine for RepRap
  • The Engine for RepRap replaces the old Engine for RapMan. Users who have the Engine for RapMan get a free upgrade

netfabb Studio 4.6 (2010/10/15)

General

  • New Menu Structure: The menu navigation and context menus of the default module and repair module have been restructured, with the Extras menu as new menu and all functions integrated into the menu bar. The old Transformations submenu has been removed.
  • New Terms: More precise terminology throughout the software. The following functions have been renamed:
old: new:
Add Annotation(Measuring tool) Add Note
Invert Normals Invert Part
Precision Plus Boolean Operations
Zoom to Selection Zoom to selected area
Calculate Self-Intersections Detect Self-Intersections
Remove Double Faces Remove Double Triangles
Refine Triangles Refine Triangle Mesh
Show Corners Show Points
Show Prehatches Show Filling
Fill Slice Create Filling


  • New Icons: A lot of new icons have been added in the menus, context menus, tabsheets and the project tree. Some old icons have been replaced, so you will have to get used to some changes. In the settings, you can also switch off the display of icons in the menus.

Some of the new icons can be seen here:

New icons.png
  • Group Colors: If you set the color of a group, all parts in the group and all parts you add to the group get the same color. If parts are moved out of the group, they get back their old color.
  • If you rotate parts by drag & drop with your mouse, you can an hold Ctrl so that parts are rotated around the closest main axis instead of an axis in your viewing direction.
  • Improved Duplicate Parts: Parts can be arranged nexttogether along all three axes. As user, you are able to define direction and distance. So, you can also choose to arrange them in a plane along two axis or in a line along one axis.
Duplicate Part.png
  • Stitch Triangles: When you stitch triangles in the repair module, it is standard to verify orientation and you can tick a box to ignore the orientation, instead of the other way round.
  • In the repair module, if you right-click on the edge of a hole you can Select the Attached Triangle Only.
  • USF file preview: With the File Preview Browser, you can now see a slice preview of USF files.
Slicepreview1.png
  • 3DS Support: netfabb can now open and export 3DS-files. 3DS is a three-dimensional file type.
  • VRML Export: VRML is a file format for three-dimensional files. netfabb is now able to export parts as VRML files.
  • Redone SLC support. netfabb now creates more efficient SLC files. SLC is a slice file format.
  • Improved import of OBJ-files.
  • In netfabb Studio Basic, you get information about features of netfabb Studo Professional.


Bugfixes
  • The Delete key can now be used to remove slices in the Slice Commander.
  • Informations are refreshed immediately when units are changed.
  • When a new project is created, netfabb automatically switches to the default module.
  • You can start the repair module in the context menu after right-clicking on a part in the project tree.
  • "Close all holes" didn't close trivial holes.
  • In the primitive list, you can use the mousewheel to scroll down.
  • The shell count did not update after some operations.
  • The software now remembers the settings of "Stitch triangles".
  • Select, move and rotate by drag & drop are accessible in the "Align" mode.
  • When parts were saved as compressed mesh, some topological information was lost.
  • Better X3D support
  • Registration and Activation can use proxy now.
  • i18n fixes.


netfabb Studio Professional

  • Free Cut: With the new free cutting tool, you can define any cutting plane and are no longer bound to the three standard planes.
Plane vertical.png
  • Shell List: In the repair module, there is a new "Shells" register in the tabsheet, where all shells of the part are listed and can be selected.
  • Cut Surfaces in mesh repair: This function in the repair module allows you draw lines freely on the surface of a part, insert these lines into the triangle mesh and cut the surface. You can view a video on this function, if you click here.
Closeline.png
Inserttomesh.png
  • Orientable Maker in MeshRepair: If you have a shell which is not orientable and you Fix Flipped Triangles, netfabb can try to make the surface orientable.
  • Part Numbers: With the option "Show Part Numbers", a number is displayed next to each part in the project tree, with the older parts always getting the lower numbers. You can "renumber parts" to get continuous part numbers.

Part numbers.png

  • Offset Hole Edges: In the repair module you can create Offsets of holes. That way, holes can be made smaller without closing them completely and surfaces can be inserted which are lying in the same plane as the triangles adjacent to the hole edges.
A hole before creating an offset. Here, an offset has been created.
  • Automatic Placement: With this function, you can arrange parts in the platform with one mouseclick.
  • In the Boolean Operations module, noise shells can be filtered. This means that tiny shells, which may come into being when substracting parts or creating intersections, can be removed automatically.
  • Improved CSV-export of platform overview.


Bugfixes
  • Improved Boolean Operations

Slice Commander

  • It is now possible to Export Slices as Image Files with the PNG, BMP, SVG, DXF or PS format. Thereby, a depiction of each slice layer can be exported into a separate image file. You have multiple options for layer size, coloration, position of the slice in the image and other parameters. You can view a video on this function, if you click here.
A slice file on the screen.
The depiction of the same slice layer in a PNG-file.

netfabb Engine for Rapman

  • Complete Redesign (to be included in netfabb Studio 4.6.2)
  • Supports
  • Improved Up/Downsides
  • Better performance and stability
  • Binary GCode
  • USB Mode (pro)
  • Heated bed support (pro)


Selective Space Structures

  • In the 3S Executor, you have the option to create empty fragments by choosing <nothing>.
  • 3S mesh export to NCM


Bugfixes
  • Volumedata are loaded correctly when you open a project and there is more than 1 set for one structure.
  • Obsolete context menu entries are removed
  • The option "invert face orientation" is added to the context area
  • The slicing process when "all transitions" are selected has been made quicker.

netfabb Studio 4.5 (2010/03/15)

General:

  • new primitives: Menger-Sponge, Moebius band, Klein bottle
  • iPhone support
  • userdefined colors for coordinate system
  • detect flipped triangles when surface is not orientable
  • background gradient support
  • X3D support
  • ASCII STL multi-solid-support
  • ASCII STL export
  • GTS support
  • WaveFront Object support
  • netfabb Compressed Mesh Support
  • highlight invalid parts

Bugfixes:

  • remember last path in file open/save dialogs if no default path is selected
  • do not select invisible parts with selection rectangle
  • fixed scaling in slice commander
  • Fixed printing bug
  • coordinate system did not respond to clicks in align mode
  • rendering of sharp edges in meshrepair
  • slicing of multipple files at once
  • reset button for cuts did not reset cutting lines
  • file extension dialog
  • part could not be saved when there was "/" or "\" in it
  • fixed installer for Vista/Windows 7

Professional:

  • renamed slice smoothing to slice point reduction
  • show save dialog when dongle is lost to prevent data loss
  • slice SVG export
  • slice TAR export
  • STL decomposition
  • duplicate/export/import/rename repair scripts

Bugfixes:

  • invalid entries when creation of new repair script is canceled
  • license file was not remembered under some circumstances

3S:

  • backfaces have different color in 3s base cell editor
  • improved transition rules: all neigbours/all cells/all transitions possible
  • library loader for sample structures
  • additional One-Click sample structures

Bugfixes:

  • expansion: new fragment had wrong preset name
  • keep cell translation for both fragments when cutting them

netfabb Studio 4.4 (2009/12/01)

General:

  • Linux version (beta)
  • optionally show all files in Meshloader
  • hatch support
  • GCode slice viewer
  • Fix problems that might lead to errors in STLs
  • degenerated faces removal
  • duplicate parts without arranging them in grid
  • redone slice animation
  • meshrepair: render bad edges behind part differently

Bugfixes:

  • correctly save/load cuts of project
  • some repairs were not correctly saved in fabbproject
  • i18n fixes
  • segfault in file preview browser
  • out-of index segmentation
  • assert in stitcher

Professional:

  • extrude
  • new repairactions for selfintersection-removal and split-off
  • new repairaction to invert shells with negative volume
  • new repairactions for degenerated faces und ghost shells
  • advanced triangle selection in meshrepair
  • redone GUI for boolean
  • slice filling: simple hatches, turtle hatches
  • rotate STL in 3S unit cell
  • structure STL export can be canceled/paused

Bugfixes:

  • Bugfixes in Boolean
  • move nodes 1 raster unit with cursors in 3S base cell
  • when duplicating structure, inputdata was not duplicated

netfabb Studio 4.3 (2009/09/25)

General:

  • proxy-support for SSL-dongle
  • advanced coordinate system
  • new primitive: text
  • slice animation
  • stitching
  • cuts colored as the corresponding axis
  • show success message when project is saved
  • moved triangle reduction prom "parts" to "view"
  • show current project in title bar
  • append number to part name when duplicating
  • export part as STL added to parts menu
  • advanced selection in meshrepair
  • open non-oriented edges
  • show degenerated faces
  • enhanced LOD
  • names for primitives

Bugfixes:

  • reduced memory consumption
  • reopen an already opened fabbproject
  • refresh part information on rescale
  • don't create new errors in meshes when saving fabbproject
  • reset cuts when selection is changed
  • remove groups
  • measuring was not correctly saved
  • measuring on parts with holes
  • slightly wrong values of wall thickness
  • slice prehatches not rotated any more
  • minor slice export fixes
  • up/down keys for changing float values in primitives
  • tabulator support in primitives
  • register button was sometimes not enabled (Basic)
  • keep selection when inserting nodes in mesh

Professional:

  • selfintersection removal
  • repair scripts
  • error highlighting
  • boolean operations (precision plus)
  • new primitives: lattice, lattice with hexagon profile

3S:

  • SplitByEnvironment possible for scripts
  • Divide Blocks can overwrite cells
  • move profiles to other structures
  • changed default cell size and grid size to 10mm
  • remember node positioning grid per cell
  • flip face orientation

Bugfixes:

  • allow nodes outside cells when override cell size is set.
  • import of ASCII STL in Basecells
  • deselect faces when clicked on node in face creation mode
  • update bar length when cell is changed

netfabb Studio 4.2 (2009/07/31)

General features:

  • improved inch support
  • Inch-to-mm/mm-to-Inch
  • reset button for cuts
  • scale equally as default
  • remember part duplicate gap
  • SSL filepreview
  • ask "remove old part" for mirror/invert normals
  • meshrepair: split triangles/bars (add nodes)
  • meshrepair: remove duplicate triangles/identify nodes
  • meshrepair: trivial stitching (2 open edges between same nodes)
  • calculations now in own thread, should fix progressbar-hangs.
  • calculations can be paused, resumed and canceled
  • manage file associations for all supported file types
  • selection tolerance now defaults to 90°
  • meshrepair: shortkey "+" and "-" for expand/shrink selection

netfabb Professional:

  • PNG export
  • USF export
  • Meshrepair: triangle refinement
  • add platform icon in tree
  • SSL+CLS+SLC+CLI export

Selective Space Structures:

  • bar/node-visualisation relative to cell size
  • support for faces in cells
  • duplicate structure
  • preview of *.3spackage and *.3scell in file browser
  • drag+drop structure to part
  • drag+drop mesh to cell/transition
  • standard cell sice, standard raster size and standard layer size in settings
  • redone orientation of profiles. should be usable now
  • additional manual rotation of profiles can be defined for each bar
  • show cell size in 3S executor
  • new buttons for cell rotation
  • enhanced STL scaling in basecelleditor: target size and equally scaling
  • drag+drop a cell to part will create a stl of the cell

Bugfixes:

  • wrong volume in standard analysis
  • Z-translation/scale in slicecommander
  • double click-deselects in file open dialog
  • drag files to netfabb, even if different module is active
  • show triangle mesh complete if sharp edges are deactivated
  • missing msvcr71.dll
  • don't create trivial holes when inserting triangles in meshrepair
  • fixed inconsistency in meshrepair: selecting triangles with shift/ctrl key pressed now behaves like everywhere else
  • rotate part while adding triangles in meshrepair
  • select bars correctly when profile is visualised
  • cell preview and translation for all selected fragments not just the last one
  • removed unneeded undo states in base cell editor
  • corrected positioning for smaller STL elements
  • corrected tree focus for simulation
  • fixed shading of bars
  • cell size --> grid size in volume data (was inconsistent)
  • rotate cell, not just the content

netfabb 4.1 (2009/06/10)

General features:

  • SliceCommander: 2D Offset
  • Cleaned up popup menu for parts
  • Inch support
  • support for big parts (>1m)
  • Self-Intersection-Detection

netfabb Professional:

  • SSL-Trial
  • Split by Environment (3S)
  • Slice to STL export

Advanced Mesh Editing:

  • Line Selector in MeshRepair
  • Extract Selected As Mesh
  • Shells To Parts
  • Merge Selected
  • 3D Offset and shell creation
  • Laplacian smoothing

Multi-platform support:

  • open multiple platforms
  • machine definitions
  • auto collision detection
  • remove colliding parts
  • multi-file-export

Bugfixes:

  • Measuring point-plane for inequally scaled parts
  • Measuring for very small parts
  • open contours in slice files

netfabb Professional 4.0 (2009/05/15)

General features:

  • select shells with negative volume in mesh repair
  • added "save as default"/"load defaults" to primitives
  • redone duplicate parts
  • show/hide selected parts
  • Added LOD 0.1%
  • redesinged mesh repair
  • color dialogs keep user defined colors
  • LOD in mesh repair
  • updated OpenSSL library to 0.9.8k
  • progress bar for mesh repair and mesh cutting
  • move to parent directory in file browser
  • improved planar triangulation

Selective Space Structures:

  • reduced memory consumption
  • use hexagon and diameter as default in profiles creation dialog

Bugfixes:

  • I18N fixes
  • ASCII STL Fix
  • outbox is updated at slice export
  • duplication of last slice layer
  • measuring: distance point-face was negative
  • SLC compatibility fixes
  • fixed tab order in transition rules
  • moved parts in 3S executor
  • refresh cuts on move/add/rotate... of parts
  • LOD fixes
Views
Personal tools